waterinjection.info  

Go Back   waterinjection.info > Aquamist specific system Q and A and resources > Aquamist HFS-4 forum

Reply
 
Thread Tools Display Modes
  #1  
Old 22-04-2017, 09:41 PM
gbmwpower gbmwpower is offline
Junior Member
 
Join Date: Nov 2016
Location: Elverson
Posts: 4
Default How to verify that the system is operating properly

I have a 2002 BMW M5 that I have installed a used HFS-4. I followed all of the test procedures stated in the instructions and everything worked properly. I drove the vehicle for about 2 months and everything was working properly. I just had the vehicle tuned for running meth and I am not sure if I am paranoid of if the system is not operating properly. I am pushing 11 psi and the vehicle accelerates so fast I have a hard time watching the guage. Sometimes when I accelerate hard it the red B flickers then both amber leds light but I don't see anything on the flow leds. It seems like the leds don't light up until close to 4.5k - 5K rpm. I thought it was supposed to kick in closer to 3,500 rpm. How to I road test the system with out risking damage to the engine?

Last edited by gbmwpower; 22-04-2017 at 10:31 PM.
Reply With Quote
  #2  
Old 23-04-2017, 08:53 AM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,898
Default Re: How to verify that the system is opening properly

There is a issue on the flow detection circuit or a clogged nozzle.
"B" denotes the system is trying to trigger but abort after no flow is detected.

If "B" led is not sustaining, turbo boost is limited to wastegate pressure, provided you have wired up the failsafe circuit correctly.

If you have a supercharged engine, the failsafe circuit has to activate a bump valve to vent boost pressure.

All the failsafe options are there, all depends how you use it.
__________________
Richard L
aquamist technical support
Reply With Quote
  #3  
Old 23-04-2017, 02:55 PM
gbmwpower gbmwpower is offline
Junior Member
 
Join Date: Nov 2016
Location: Elverson
Posts: 4
Default Re: How to verify that the system is opening properly

Ok thanks. It is Supercharged with 3 nozzles. The B is supposed to light up solid when working properly? I will test the nozzles again manually how do I test the flow detection circuit? Both the flow sensor and the fav cable are new.

Update

Tested the pump, fav, and all nozzles, everything is working properly there.

Last edited by gbmwpower; 23-04-2017 at 05:08 PM.
Reply With Quote
  #4  
Old 23-04-2017, 05:56 PM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,898
Default Re: How to verify that the system is opening properly

B will light iup if the system is working properly. If this is not flow detected, B will go off.

You have already tested the flow sensor, blowing through it etc. If you hear whirling sound and no display, it might be the yellow flow sensor cable got damaged.

What is the serial number of your system?
__________________
Richard L
aquamist technical support
Reply With Quote
  #5  
Old 23-04-2017, 06:06 PM
gbmwpower gbmwpower is offline
Junior Member
 
Join Date: Nov 2016
Location: Elverson
Posts: 4
Default Re: How to verify that the system is opening properly

Serial is 121287
Reply With Quote
  #6  
Old 23-04-2017, 06:45 PM
gbmwpower gbmwpower is offline
Junior Member
 
Join Date: Nov 2016
Location: Elverson
Posts: 4
Default Re: How to verify that the system is opening properly

Just drove it again, seems to be working correctly. I did have a sharp angle on one of one of the hoses. It starts to activate around 4-4.5k rpm I did not notice any flickering of the B this time. I will keep an eye on it.

Could you tell me the best way to determine the optimal trigger rpm? I believe it is controlled by injector pulse.

Thanks
Reply With Quote
  #7  
Old 23-04-2017, 09:59 PM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,898
Default Re: How to verify that the system is opening properly

The system does not read rpm.
__________________
Richard L
aquamist technical support
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.