waterinjection.info  

Go Back   waterinjection.info > Aquamist specific system Q and A and resources > Aquamist HFS-4 forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-07-2019, 04:39 PM
BMC123 BMC123 is offline
Junior Member
 
Join Date: Sep 2016
Location: canada
Posts: 8
Default Need help setting up Aquamist to run based on boost alone

I have a 2013 Mazdaspeed 3 that is built and fully bolted (425ish WHP). I'm running the Aquamist HFS4-v3.1 using 2 jets, a .8 and a 1. Both of these feed into a spacer on the throttle body. My tuner (Freektune) advises that he prefers to set up his tunes running water/meth injection based solely off of boost. He has asked that I set up the system to start water/meth flow at 10psi and be running full at 15psi. Can you suggest how I might achieve that with any degree of accuracy? It appears that the Aquamist system is biased toward running off of IDC. The kit is fully installed, it's just the jumper-links and trim that are causing the confusion. I find portions of the instruction manual to be ambiguous. Thanks in advance.


initial installs - all COBB; FMIC, Accessport V3, SF Cold Airbox, Short Ram Intake, Turbo Inlet Hose, 3" SS Downpipe, 3" SS Cat-back Exhaust, Rear Motor Mount, XLE BPV, Polyurethane Exhaust Hangers. Autotech Fuel Pump Internals, Greddy catch can, Freektune.

Most recent installs/swaps; BNR S4 , HTP 3" intake kit, , TIG intake to head, CPE EGR delete, Swift lowering springs, rear camber arms, CPE 75 duro driver and passenger mounts, ProMeth Tank, Aquamist HFS-4 V-3 w/m injection kit (to combat our absolutely garbage, 91 octane), (.8 & 1.0 jets), vent gauge pod, Nitto NT05s

Built Motor - Manley H-beam rods, Wiseco pistons and CS cams, balance shaft delete

Last edited by BMC123; 06-07-2019 at 07:00 PM.
Reply With Quote
  #2  
Old 06-07-2019, 08:39 PM
BMC123 BMC123 is offline
Junior Member
 
Join Date: Sep 2016
Location: canada
Posts: 8
Default Re: Need help setting up Aquamist to run based on boost alone

It appears there are discrepancies between my user manual for the HFS4-v3.1 and the downloadable version on this site (pg. 14, under TRIG, there's no mention of the P+I jumper link). There is an extra TRIG jumper-link slot on my system board (it's called the P+I trigger) for boost and IDC combined. I'm guessing that was removed on later iterations of the system as it looks like the same results could be achieved with the P/I-R trimmer. Not sure.

Anyway, does anyone know if it matters to the P/I-R trimmer, which TRIG you've selected (MPS or IDC)? Also, on the bottom of pg.13 of the manual, in describing the LED panel, it references the RED (95% DC) but the diagram at the top left of the page shows the RED LED indicating 95% IDC. One appears to reference the injector duty cycle of the fuel system and the other seems to be referencing the duty cycle of the Aquamist. Thoughts?

Last edited by BMC123; 06-07-2019 at 08:56 PM.
Reply With Quote
  #3  
Old 07-07-2019, 01:50 AM
RICE RACING RICE RACING is offline
Senior Member
 
Join Date: Oct 2003
Location: Utopia
Posts: 444
Default Re: Need help setting up Aquamist to run based on boost alone

I set them all to IDC, its not hard to work out. Maybe find someone competent?
__________________
http://www.riceracing.com.au
RICESP > F40 > Zonda > ZR1
Water Injection Specialist
"Can't be defeated!, don't know the word!, shoulder to shoulder!, we'll fight the world!, WE CAN'T BE BEATEN!!!"
Reply With Quote
  #4  
Old 07-07-2019, 05:02 AM
BMC123 BMC123 is offline
Junior Member
 
Join Date: Sep 2016
Location: canada
Posts: 8
Default Re: Need help setting up Aquamist to run based on boost alone

Thanks for the reply but I've got a fairly competent tuner (https://www.youtube.com/watch?v=vSl9pBnHmPY). I just need someone who is familiar enough with the Aquamist water/meth system, to help me set it up the way he wants it. Then he can go about his business of making me go fast. I just don't get some of the jumper-link and trim settings. As expressed in my above posts, the discrepancies in the hard copy of the manual and the digital copy, have me confused.
Reply With Quote
  #5  
Old 07-07-2019, 05:57 AM
RICE RACING RICE RACING is offline
Senior Member
 
Join Date: Oct 2003
Location: Utopia
Posts: 444
Default Re: Need help setting up Aquamist to run based on boost alone

The IDC is directly proportional to the boost level though thus my point.
__________________
http://www.riceracing.com.au
RICESP > F40 > Zonda > ZR1
Water Injection Specialist
"Can't be defeated!, don't know the word!, shoulder to shoulder!, we'll fight the world!, WE CAN'T BE BEATEN!!!"
Reply With Quote
  #6  
Old 09-07-2019, 05:56 PM
BMC123 BMC123 is offline
Junior Member
 
Join Date: Sep 2016
Location: canada
Posts: 8
Default Re: Need help setting up Aquamist to run based on boost alone

Just in case anyone else is ever interested in basing their set up off boost alone, the following should help. It appears the way to set the system up to trigger at 10 and be maxed at 15 psi is to jumper link MPS, dial the P-I/R trimmer fully counterclockwise and then adjust THRES till trigger is at 10psi and GAIN, till full flow is at 15psi.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.