waterinjection.info  

Go Back   waterinjection.info > Aquamist specific system Q and A and new products > Aquamist HFS-3 forum

Reply
 
Thread Tools Display Modes
  #1  
Old 20-07-2019, 01:15 PM
kenrevo kenrevo is offline
Junior Member
 
Join Date: Nov 2015
Location: USA
Posts: 3
Default Gauge on/off button not working. System enabled but not working

I have a hfs-3 system, about 4 years old, and it recently stopped working. I noticed that the gauge was off, I pressed the button and it would turn on then off. I pressed it a couple more times thinking the contacts are just dirty and needed to be moved and it worked the gauge stayed on. Even thought the gauge is on, the system isn't working properly. I can't boost beyond wastegate pressure but if I remove the DHB jumper I can boost over wastegate pressure so I know the issue is with the system not the car. Any thoughts on the issue? I'm thinking I need to get a new gauge.
Reply With Quote
  #2  
Old 20-07-2019, 08:11 PM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,936
Default Re: Gauge on/off button not working. System enabled but not working

We can repair the newer ones if you send it back to us, we don't charge.. What is the version number or the serial number of the controller?
__________________
Richard L
aquamist technical support
Reply With Quote
  #3  
Old 21-07-2019, 01:52 PM
kenrevo kenrevo is offline
Junior Member
 
Join Date: Nov 2015
Location: USA
Posts: 3
Default Re: Gauge on/off button not working. System enabled but not working

Richard that would be great. Its a v3.1 SN:102337 , if it can be repaired let me know and I'll send it back to you.
Reply With Quote
  #4  
Old 21-07-2019, 02:34 PM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,936
Default Re: Gauge on/off button not working. System enabled but not working

Border line. send it anyway, we will find a way. It is a made in 2015

Shipping address:
(write "return to manufacturer for repair" or tax will be charged. Value is $10)

ERL Ltd
Iroko house
Bolney Ave. Peacehaven
East Sussex BN10 8HF
England
T: +44 1273 581007
F: +44 1273 581555
__________________
Richard L
aquamist technical support
Reply With Quote
  #5  
Old 17-08-2019, 03:24 PM
Richard L Richard L is offline
Manufacturer sponsor
 
Join Date: Oct 2003
Location: England
Posts: 4,936
Default Re: Gauge on/off button not working. System enabled but not working

Your gauge is repaired, please email me richard-at-aquamist-co-uk.
__________________
Richard L
aquamist technical support
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:49 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.